Go Back   V6 F-Body.com > Rides, Modifications & Racing > Showcase
Showcase A forum dedicated completely to exhibition of your mods!

Reply
 
Thread Tools Display Modes
  #21  
Old 08-28-2012, 10:32 PM
Throwback Bird's Avatar
Throwback Bird Throwback Bird is offline
Phantom 207
LS Supporting Member


 
Join Date: Aug 2010
Location: Macon GA
Rank: First Lieutenant
Posts: 2,728
Default

you better keep it and show up to G17.
__________________

3.4L with some goodies
custom paint with a touch of 1978
http://www.v6f-body.com/showthread.php?t=3065
Reply With Quote
  #22  
Old 08-29-2012, 08:59 AM
xpbr2000's Avatar
xpbr2000 xpbr2000 is offline
Droner
LS PLUS Supporting Membership
Administrator


 
Join Date: May 2010
Location: Mooreville, MS
Rank: Freaky Poster
Posts: 11,337
Default

Yeah there will be a major ass whoop'in if a certain member doesn't show at g17.
__________________

96 Camaro Cam'd anti-Coupe
Dyno'd @ 213 RWHP (NA)
"OperationX"
Reply With Quote
  #23  
Old 08-29-2012, 11:08 AM
kdm212 kdm212 is offline
Another day in paradise...right?!?
LS PLUS Supporting Membership


 
Join Date: Feb 2010
Location: Ocklawaha, Florida
Rank: Captain
Posts: 2,925
Default

Quote:
Originally Posted by 1-Kustombird View Post
you better keep it and show up to G17.
i WILL be there!

Quote:
Originally Posted by xpbr2000 View Post
Yeah there will be a major ass whoop'in if a certain member doesn't show at g17.
no beatings for me!!!
__________________
Thanks to Dustin for my sigpic!!!
My F-Body history: http://www.v6f-body.com/showthread.php?t=4352
Current car: http://www.v6f-body.com/showthread.php?t=4522
Reply With Quote
  #24  
Old 08-29-2012, 12:39 PM
Video's Avatar
Video Video is offline
Back in Black


 
Join Date: Jan 2012
Location: Cape Cod, MA
Rank: Sergeant Major
Posts: 1,701
Default

My high beams didnt work when i got mine too. The rod wasnt making contact with the plunger underneath the dash. Was a quick easy fix. Maybe thats all thats wrong with yours?
Reply With Quote
  #25  
Old 08-29-2012, 01:04 PM
xpbr2000's Avatar
xpbr2000 xpbr2000 is offline
Droner
LS PLUS Supporting Membership
Administrator


 
Join Date: May 2010
Location: Mooreville, MS
Rank: Freaky Poster
Posts: 11,337
Default

it most likly is. where did you say the plunger was. under the dash?
__________________

96 Camaro Cam'd anti-Coupe
Dyno'd @ 213 RWHP (NA)
"OperationX"
Reply With Quote
  #26  
Old 08-29-2012, 02:05 PM
snowcolt17's Avatar
snowcolt17 snowcolt17 is offline


 
Join Date: Mar 2012
Location: AL
Rank: First Sergeant
Posts: 1,262
Default

Quote:
Originally Posted by Video View Post
My high beams didnt work when i got mine too. The rod wasnt making contact with the plunger underneath the dash. Was a quick easy fix. Maybe thats all thats wrong with yours?
i think thats whats wrong with mine... they dont click and dont try to come on... more info?
Reply With Quote
  #27  
Old 08-30-2012, 07:19 AM
kdm212 kdm212 is offline
Another day in paradise...right?!?
LS PLUS Supporting Membership


 
Join Date: Feb 2010
Location: Ocklawaha, Florida
Rank: Captain
Posts: 2,925
Default

im in the same boat. i will be investigating this today/tonight.
__________________
Thanks to Dustin for my sigpic!!!
My F-Body history: http://www.v6f-body.com/showthread.php?t=4352
Current car: http://www.v6f-body.com/showthread.php?t=4522
Reply With Quote
  #28  
Old 08-31-2012, 09:14 AM
Video's Avatar
Video Video is offline
Back in Black


 
Join Date: Jan 2012
Location: Cape Cod, MA
Rank: Sergeant Major
Posts: 1,701
Default

Yup! The click comes from the little plunger thingy. If its not clicking that would be why! This is such an easy fix! I believe its a screw or two that you can loosen to adjust the plunger. Yeah you know the plastic guard that covers all the wiring etc. underneath the steering wheel? It's in there. You may need to disconnect some wiring it get at it though. Adam helped me fix it, and he had to disconnect the brake light wiring etc.

Last edited by Video; 08-31-2012 at 09:19 AM.
Reply With Quote
  #29  
Old 08-31-2012, 09:18 AM
xpbr2000's Avatar
xpbr2000 xpbr2000 is offline
Droner
LS PLUS Supporting Membership
Administrator


 
Join Date: May 2010
Location: Mooreville, MS
Rank: Freaky Poster
Posts: 11,337
Default

good to know. i'll take pics for a possible write when i do mine.
__________________

96 Camaro Cam'd anti-Coupe
Dyno'd @ 213 RWHP (NA)
"OperationX"
Reply With Quote
  #30  
Old 08-31-2012, 09:19 AM
Video's Avatar
Video Video is offline
Back in Black


 
Join Date: Jan 2012
Location: Cape Cod, MA
Rank: Sergeant Major
Posts: 1,701
Default

Quote:
Originally Posted by xpbr2000 View Post
good to know. i'll take pics for a possible write when i do mine.
YAY! I made a useful contribution!
Reply With Quote

Go Back   V6 F-Body.com > Rides, Modifications & Racing > Showcase
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:41 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
2008 - 2018 V6F-Body.com