Go Back   V6 F-Body.com > Technical Discussion > 3.4 L Specifics
3.4 L Specifics The 93 - 95 3.4L V6

Reply
 
Thread Tools Display Modes
  #1  
Old 05-22-2017, 03:09 PM
Ozzy Ozzy is offline


 
Join Date: May 2017
Rank: Private
Posts: 3
Default 7.5amp fuse blowing on the injectors. 95--3.4

Need help. My sons 95 3.4 is blowing the passages side fuse for the injectors. Had new injectors put in and a new pmc.
Not sure where to check .. has anyone had the problem before?
Thanks
Reply With Quote
  #2  
Old 05-22-2017, 03:24 PM
xpbr2000's Avatar
xpbr2000 xpbr2000 is online now
Droner
LS PLUS Supporting Membership
Administrator


 
Join Date: May 2010
Location: Mooreville, MS
Rank: Freaky Poster
Posts: 11,177
Default

do they blow immediately when the car turns on? or when under throttle?

if its immediate i'd unplug all the injectors (or at least the side that is cause the problems)
with the key off plug one in and turn the key on to see if it blows the fuse. when you find the culprit you can diagnose it further.
__________________

96 Camaro Cam'd anti-Coupe
Dyno'd @ 213 RWHP (NA)
"OperationX"
Reply With Quote
  #3  
Old 05-22-2017, 09:13 PM
Ozzy Ozzy is offline


 
Join Date: May 2017
Rank: Private
Posts: 3
Default

Quote:
Originally Posted by xpbr2000 View Post
do they blow immediately when the car turns on? or when under throttle?

if its immediate i'd unplug all the injectors (or at least the side that is cause the problems)
with the key off plug one in and turn the key on to see if it blows the fuse. when you find the culprit you can diagnose it further.
At first it didn't blow right away.coulddrive it for a day . But now it blows right away , will have him try what u said. Thanks.
Reply With Quote
  #4  
Old 05-24-2017, 01:16 AM
xpbr2000's Avatar
xpbr2000 xpbr2000 is online now
Droner
LS PLUS Supporting Membership
Administrator


 
Join Date: May 2010
Location: Mooreville, MS
Rank: Freaky Poster
Posts: 11,177
Default

could be a short on the harness. the short may not have occurred until you drive it some and the vibration caused the short. not sure, but poosible.
__________________

96 Camaro Cam'd anti-Coupe
Dyno'd @ 213 RWHP (NA)
"OperationX"
Reply With Quote
  #5  
Old 05-24-2017, 01:34 AM
xpbr2000's Avatar
xpbr2000 xpbr2000 is online now
Droner
LS PLUS Supporting Membership
Administrator


 
Join Date: May 2010
Location: Mooreville, MS
Rank: Freaky Poster
Posts: 11,177
Default

it just occurred to me that if the short is in the harness and you move the harness a little it may resolve the short or at least until it finds itself again.

but hopefully it will be pretty straight forward.
__________________

96 Camaro Cam'd anti-Coupe
Dyno'd @ 213 RWHP (NA)
"OperationX"
Reply With Quote
  #6  
Old 05-24-2017, 07:41 AM
Ozzy Ozzy is offline


 
Join Date: May 2017
Rank: Private
Posts: 3
Default

Thanks
Reply With Quote

Go Back   V6 F-Body.com > Technical Discussion > 3.4 L Specifics
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:20 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
2008 - 2017 V6F-Body.com